Some users prompted to enter the start code when opening the app, even though the system was already set up.

Incident Report for gridX GmbH

Postmortem

A bug in the routing logic of our white-label end user apps caused users to be routed to the commissioning wizard instead of their dashboards on opening the app.

Resolution

  • The final fix for the white-label end user app routing logic was deployed at 2025-12-11 12:11 PM CET.
  • Between 2025-12-12 02:59 PM CET and 2025-12-18 06:45 PM CET, the affected system configurations have been fixed automatically or manually for edge cases.

Action Items

  • Improve alerting to indicate anomalies in wizard state distribution throughout the complete fleet

Detailed Information

The bug affected users with systems initially provisioned before 2025-07-28. It has been deployed and active between 2025-12-08 11:43 AM CET and 2025-12-10 01:26 PM CET, as well as between 2025-12-11 11:35 AM CET and 2025-12-11 12:11 PM CET, but might have affected some users still up to 24h after mitigation due to CDN and browser caching.

Some of the affected users proceeded to go through the commissioning wizard flow again (by clicking on the Start, Next or Back buttons), which caused the wizard status of their systems having been reset from DONE to other states such as STARTCODE or WELCOME in our database. Due to this, these users were still stuck in the commissioning wizard even after the bug in the app has already been fixed. Most of these can access their dashboards again since their system’s data had been corrected by us by 2025-12-11 02:59 PM CET.

A small number of affected users with hybrid inverters triggered a new scan of assets through the commissioning wizard, but were unaware that the rediscovered hybrid inverter required manual adjustments through the commissioning wizard (such as setting the hybrid inverter’s type). This led to these hybrid inverters having been wrongly labeled as type UNKNOWN in our database, which rendered them not controllable by the EMS (e.g. for time of use optimization) and had them fall back to self-sufficiency optimization. For most of them, we could recover the previous hybrid PV inverter configuration by 2025-12-12 11:45 AM CET and made them controllable by the EMS again. The remaining ones are being are being investigated and fixed manually.

We verified, that no §9 EEG control boxes were among systems with broken hybrid inverter configuration.

Posted Dec 19, 2025 - 15:34 CET

Resolved

A faulty deployment on Dec. 8th, 11:43 GMT, reset the wizard completion status to the beginning of the commissioning process for some systems. This led to the commissioning wizard being shown instead of the app when users opened it.

During the incident, their systems kept operating as usual, no data was lost and the energy consumption optimization was still running.

The offending deployment was reverted.

The affected system's wizard completion status is now being corrected, this is still ongoing and will be finished before EOB.
Posted Dec 11, 2025 - 13:44 CET
This incident affected: Frontend.