Closing this incident as the major issues have been addressed. We will continue to correct the old calculations due to DST in the coming days.
Posted May 28, 2025 - 23:54 CEST
Monitoring
We have backfilled energy measurements for May 23rd till May 26th, and October 2024.
The remaining months will be done over the next week.
Posted May 28, 2025 - 20:16 CEST
Identified
During an internal data migration, we ran into 2 issues affecting historical energy measurements (day, week and month):
1. On May 23rd we only have partial data, and from May 24th till May 26th we are missing all data. 2. In March and October months, from 2018 till 2024 we could be missing data due to previous Daylight Savings Time issues. Not all data was migrated, and data that was, may be inaccurate.
Issues calculating energy consumption due to DST were resolved in late 2024. In some cases, this resulted in duplicate data, which is why it wasn’t migrated.
We will run backfills for all affected time intervals, to correct the situation. This will take time.
Posted May 28, 2025 - 11:09 CEST
This incident affected: Platform Components (beta) (Measurement API).