The fix is working as expected. We'll post a post mortem within the week.
Posted Mar 26, 2025 - 11:30 CET
Monitoring
A fix has been deployed, the /gateways/.../scans endpoint is back up. We're seeing expected behavior and continue monitoring.
Posted Mar 26, 2025 - 11:19 CET
Update
We are about to roll out an optimized version of the endpoint in question.
Posted Mar 26, 2025 - 10:41 CET
Identified
We're experiencing an elevated level of API errors on the /gateway/.../scans endpoint. This is due to the mitigation of the previous incident tonight and a conscious decision to safeguard operations during the night.
The effect is that you'll see 404s on that endpoint, i.e. gateway scans cannot be retrieved. XENON dashboard will show an empty list of scans.
We'll keep it like this through the night and bring it back tomorrow. We apologize for having caused you issues.