Some inverters fell back to self-sufficiency optimization

Incident Report for gridX GmbH

Postmortem

Due to some missing cryptographic certificates, gridBoxes were unable to establish trusted connections to two public backends required for the integration of the following two asset families:

  • Enphase Envoy S inverters
  • RSW Fiege meters

As a result, gridBoxes were unable to refresh the associated security tokens once those tokens had reached their expiration date.

Affected assets fell back to self-sufficiency optimization during the incident.

Root Cause

Critical cryptographic certificates were accidentally excluded from a software package following an internal change in gridX’s software release process.

Resolution

The critical cryptographic certificates were restored in the offending software package.

Action Items

Our alerting was updated to catch asset online/offline status anomalies.

Posted Jan 12, 2026 - 16:32 CET

Resolved

Due to some missing cryptographic certificates, gridBoxes were unable to establish trusted connections to two public backends required for two asset drivers. This led to falling back to the affected inverters internal optimization logic.
The issue was fixed on Jan 8th. 12:00.
Posted Jan 06, 2026 - 23:30 CET